Your cart is empty.
×
Your cart is empty.

Worship Essentials

Filter

Showing all 6 results

Sort By

Filter by price

Average rating

  • $40.00
    Quickview

    Worship Essentials 2

    Software requirements: 
    • MainStage 3 version 3.2.4 or higher is required
    $40.00
    Rated 5.00 out of 5
    $40.00
  • $35.00
    Quickview

    Worship Guitar Essentials

    Software Requirements: MainStage users version 3.2.4-3.3 is required. Logic Pro X users, version 10.2.4 or higher is required. We DO NOT recommend updating to macOS 10.14 Mojave or MainStage 3.4+ at this time!!
    $35.00
    Rated 4.50 out of 5
    $35.00
  • $50.00
    $50.00
  • $25.00
    Quickview

    Worship Essentials For Omnisphere

    Software Requirements: Omnisphere version 1 or 2
    $25.00
    $25.00
  • $35.00
    Quickview

    Bass Essentials

    Software Requirements: MainStage version 3.2.4 or higher Logic Pro X version 10.2.4 or higher
    $35.00
    $35.00
  • $50.00
    Quickview

    Worship Essentials Plus for Ableton Live

    Software Requirements:
    • Ableton Live 9.7.5+ Standard or Suite
    • Spectrasonics Omnisphere 2
    • Native Instruments: The Giant
    • Native Instruments: Scarbee Mark 1
    • Valhalla Shimmer
    $50.00
    $50.00